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Quickstart Guide for eXe  

This Quickstart Guide covers how to: 

 Download eXe to a computer. 

 Create and edit learning content and activities with eXe. 

 Export content to Moodle.  

1. About eXe 
eXe is a freely available Open Source application for designing and publishing web-based 

teaching and learning materials.  This easy to use authoring tool enables teachers to 

organise content and activities into interesting, engaging and learner-centred online 

learning resources.   

eXe can be downloaded from:  http://sourceforge.net/projects/exe/ . The download page 

looks like this: 

 

Click on the Download button and follow the instructions to install it on your computer. It 

will take about 10 -12 minutes to download. 

 

Useful resources for learning about eXe:  

 Within eXe there is an eXe tutorial under the Help menu.  

 eXe Online manual  

 Refer to the guidelines and tips provided in the OP Moodle Staff Resources book called 

Guide to file formats for Moodle resources 

 

http://sourceforge.net/projects/exe/
http://www.wikieducator.org/Online_manual
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2. Open eXe  
When you open the eXe programme it looks like this.  It contains an Outline area for adding 

and organising pages, a group of tools called iDevices for presenting and structuring 

content, and an Authoring window where content is added and edited.    

 

 

 3. Add and organise pages 
Add one or more pages in the Outline area by clicking the Add Page button. When a page is 

selected you can rename it using the Rename button or by double clicking on the page.  
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4. Free Text iDevice   
This tool is used for adding text, images, and embedding media eg sound files, flashfiles. 

Select a page to add content to.  Open the Free Text iDevice. This is what it looks like in edit 

mode with some text added.  
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Clicking the green tick control button records the content and switches the view to preview 

mode. (Beware this does not save your work; to save your work click on the File Menu and 

select Save As ... It will be saved as an eXe package file (.elp file) which you can return to 

later). 

This is what it looks like in preview mode. 

 

 
Deleting iDevices  

To delete the Free Text iDevice and its contents, or any other iDevice, simply click on the red 
cross control button.  

4A. Adding content  
In most of the iDevices content is entered and formatted using the editing toolbar.  Many of these 

editing tools will be familiar from Word documents. 

 

 

These tools may be less familiar: 

Anchor: inserts an anchor for internal linking (via the chain text-link button); only supported in 

exports of type Web Site  

Paste clipboard as text, and Paste from Word (cleans up some Word formatting but not all)  

Image: insert an image into your content (to link to a URL or to embed a file); or edit its 

properties  
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Media: insert a media clip into your content (to link to a URL or to embed a file); or edit its 

properties  

Text Link: insert a link (to an external URL, an internal anchor, or to embed an attachment 

file); or edit its properties; or remove the link (via the broken-chain button)  

HTML raw source editor (advanced users only)  

 

Text 

1. Open the Free Text iDevice.    

2. Copy and paste text from a Word document into the text window (refer to Tips 

below to avoid problems with this), or type directly into the text window.   

Tips: 

Copying and pasting text directly from Word documents and other formatted sources may 

cause some problems when you export and upload the eXe learning package, for example 

html code will suddenly be present around your text especially bullet points although it 

wasn’t obvious in the working eXe package (.elp file).  To avoid this problem paste text into 

Notepad first to remove most of the formatting (copy from Word, open Notepad from your 

Program list under Accessories, paste text, remove bullet points and other obvious 

formatting remaining in the text, select all the text and copy, then paste into the eXe text 

box, reformat and Insert).  

The default font is very small and not very readable on screen. A font such as Ariel font size 

3 (12pt) is much more reader-friendly. 

Avoid filling the pages with loads of text that readers have to scroll through. If you have a 

large amount of reading text, it would be better to provide it as an attached pdf file. 

Take care with your spelling as there is no spell-check provided in eXe. 

 

4B. Links and attachments  

When a document is attached, eXe takes a copy of it and saves it as part of the eXe package. 

Linking out to a website takes you directly to the website but does not take a copy of the 

website. 
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Add hyperlinks and attachments using the text link and unlink editor buttons (chain 

buttons in Editing Toolbar).   

1. Highlight and select the text word or short phrase which will become the link source.   

2. Open the link editor and specify the web URL for a web link or click on the browser 

button to choose a local file document to attach.  

3. Select Open in new window from the Target drop-down menu.  Click Insert.   

4. Click the green tick control button to switch to preview mode.  

 

Tips: 

Check the attached document is easy to read on screen; if students need to print it off 

provide it as a pdf. 

 

4C. Images 

eXe allows you to include .jpg, .gif and .png image files into your content. 

Insert images using the image editor button (tree icon in Editing Toolbar); note that images 

cannot be copied and pasted from word documents.    

1. Open the image editor and specify the web URL or click on the browser button to 

choose a local image file.  (The image URL must include the image file-type eg .jpg)    

2. If needed, specify the dimensions and alignment around text (click the Appearance 

tab).    

3. Click Insert.  Adjust the image size to fit.   

4. Click the green tick control button to switch to preview mode.    

To modify an image once it has been added into the content, click the pencil editing button 

at the bottom left to switch to edit mode.  Select the image by clicking on it: click the image 

editor button or right-click to see the image menu and open Image Properties to return to 

the image editor.  
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Tips: 

Check the KB size of local file-based images before inserting them into your eXe package to 

see whether they need to be resized.  Hover your mouse over the image file to reveal its 

size; if it’s larger than 100 KB it should be resized.  Use MS Office Picture Manager to resize 

or compress your images.  (See ‘Resizing images using MS Office Picture Manager’ in 

Moodle Resources (access at OP Moodle: Staff Resources). 

Check the copyright on images.  Flickr has a huge collection of images with a creative 

commons licence which are freely available to use.  Remember to attribute the source of 

your image.    

 

4D. Sound files and Powerpoints 

The best format for adding sound files to your eXe package is as MP3 files.  (WAV and WMA sound 

files may not work and should be converted to MP3; see Tips below guidelines).  

Powerpoints should be converted to Flash files (swf) before being inserted in to your content (see 

Tips below). 

Insert sound files and flash files using the media editor button (filmstrip icon in Editing 

Toolbar).    

1. Open the media editor and select the appropriate option from the Type drop-down 

menu: for example MP3 for sound files, ShockWave Flash SWF for previously 

converted powerpoint presentations.    

2. Specify the web URL or click on the browser button to choose a local file.  Click 

Insert.   A media object outline will appear.   

3. Click the green tick control button to switch to preview mode.   

To modify a media file once it has been added into the content, click the pencil editing 

button to switch to edit mode.  Select the media object outline: click the media editor 

button or right-click to see the media object’s menu. 

Tips: 

You can use an application called Audacity to record sound files.  Download Audacity from 

here; you need both Audacity 1.2.6 and the LAME MP3 encoder from here.  Guidelines for 

‘How to use Audacity’ (including converting WAV to MP3) and ‘How to convert WMA files 

into MP3’ are provided in Moodle Resources (access at OP Moodle: Staff Resources). 

http://www.flickr.com/creativecommons/
http://audacity.sourceforge.net/download/windows
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Keep powerpoint presentations to a manageable size (say 15 slides).  Once you have 

completed the Presentation (with sound attached if you are adding voice-over), it can be 

quickly and easily converted into Flash (.swf file) using iSpring.  Downloaded iSpring to your 

computer, reopen the powerpoint and the iSpring Converter should be present in your 

main menu.  Click Publish from the iSpring menu bar. This will produce 3 files one of which 

is the .swf file (Shockwave flash). The .swf file can now be added to your content. (See ‘How 

to turn your Powerpoint into Flash using iSpring’ in Moodle Resources (access at OP 

Moodle: Staff Resources). 

 

YouTube videos 

Insert YouTube videos using the media editor button.   

1. Copy the URL for the video clip.  Open the media editor and paste the URL into the 

File/URL field and press [ENTER].    

2. The ShockWave Flash SWF will be automatically selected and the video will preview 

within the media window.   Click Insert.   

3. A media object outline will appear.  Click the green tick control button to switch to 

preview mode.   Modify as for other media.   

Other iDevices 
There are a number of other iDevices that can be used to present content and activities and 

provide learner guidance, for example objectives, case study, reading activity, reflection and 

question types.  

You can construct your own iDevices using the Tools menu in eXe and open the iDevice 

Editor. 

Saving  
When you have finished entering content, clicking the tick control button switches to 

preview mode.  This does not save your work; to save your work click on the File Menu and 

select Save As ...  It will be saved as an eXe package file (.elp file) which you can return to 

later.  

To close an eXe file click on the File menu and select Quit.  

http://www.ispringsolutions.com/products/ispring_free.html
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Merging: inserting and extracting  
In the File menu the Merging option allows you to take an elp file and merge the content of 

that file into another elp file, or to take a page from an elp file and extract it to create a new 

elp. 

Open the .elp file you will be adding the new material into, select the node (“page” in your 

file) you wish to insert the content into, then select Merge -> Insert Package from the File 

menu.  (Alternately, you can right-click on a node and select Insert Package). The Browser 

dialogue is displayed. Browse to the .elp file you want to insert and click Open. The new file 

content will now appear in your open .elp file.  This adds the entire .elp file, which you can 

reconstruct by editing/deleting pages as needed. 

To extract a node (pages and all the pages sitting beneath it), select the node from your 

open .elp file, select File, Merging, Extract Package (or right-click). A save dialog is 

displayed. Enter a file name for the node you are extracting and click Save. A confirmation 

message will be displayed. 

Exporting, Printing  
 

Exporting and uploading to Moodle 

To export, click on the File menu and select Export -> IMS Content Package.  In Moodle, 

upload the package file to your course storage folder as normal.  From the course page 

where the eXe package will be displayed, view the drop-down resource menu and select 

Add an IMS content package.  Complete the editing page to link to the zipped eXe file; 

select the correct setting to open in a new window.  Now click the Save and display button 

at the bottom of the page, then Deploy to enable the package to be accessed.  The eXe 

package will now appear on your course page.  

Printable copies of eXe packages 

There are two ways of providing a printable copy of an eXe package. 

1. Open the .elp file and convert into a PDF version using the File -> Print menu.  This 

produces pages as they appear in the eXe package. 

2. Convert a Word document containing the most relevant parts of the eXe package 

into a PDF version.  

 

If you require any assistance using eXe please contact EDC.                                 
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